ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Hatton" <khat...@axiomsystems.com>
Subject RE: Problem with junit in ant with jdk 1.4.1
Date Tue, 19 Nov 2002 17:28:51 GMT
Is that "it works with any 5 of the 6" or is it actually "there's something different about
this sixth test" ?


-----Original Message-----
From: Steve Schlaifer [mailto:steve@kihakkt.jetcafe.org]
Sent: 19 November 2002 17:20
To: Ant Users List
Subject: Re: Problem with junit in ant with jdk 1.4.1


On Sun, 17 Nov 2002, Steve Loughran wrote:

> Its a result of a stricter classloader in ant1.5 that doesnt expose all the
> many extra things that were stuck in java1.4. the cvs version of ant does
> expose more, but if you enable forking then things work just as well in
> ant1.5. Forked jvms are better for unit tests anyway, as they dont break
> your build when very bad things go wrong in the app

You're probably right but it does seem curious to me that it runs fine
when there are only 5 tests and fails when there are 6.

		--Steve

       "Perhaps God gave man free will so he
       could choose to stop those who had chosen evil."
       <James Lileks>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message