ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Hatton" <khat...@axiomsystems.com>
Subject RE: NoClassDefFoundError
Date Tue, 19 Nov 2002 09:22:41 GMT
Looks like you may hav spaces in your CLASSPATH. Try putting it in quotes or converting to
shortened filenames.

Keith


-----Original Message-----
From: Nick [mailto:nick.patania@ntlworld.com]
Sent: 17 November 2002 18:00
To: ant-user@jakarta.apache.org
Subject: NoClassDefFoundError


Hi, I'm new to Ant and when trying a simple build.xml I get a 
NoClassDefFoundError. The reason I get the error is because the files 
are being looked for with dots (".") replaced by slashes ("/"). Any idea 
why this might happen?

Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.

C:\>d:

D:\>cd work\year4\individual project\design assistant

D:\Work\Year4\Individual Project\Design Assistant>ant
Exception in thread "main" java.lang.NoClassDefFoundError: 
Files\j2sdk1/4/1_01\lib\tools/jar;C:\Ant\lib\xml-apis
/jar;C:\Ant\lib\xercesImpl/jar;C:\Ant\lib\optional/jar;C:\Ant\lib\ant/jar;C:\Ant\lib\ant/jar;
D:\Work\Year4\Individual Project\Design Assistant>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message