ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colin Truesdale <>
Subject Re: javadoc OutOfMemoryError
Date Wed, 27 Nov 2002 16:20:16 GMT
I have a (somewhat) similar problem - have been using exec to execute an 
ant target for Javadoc using 1.4's Javadoc.
When the exec fails (due to errors in the actual Javadoc in my code), it 
does not cause ant to fail, even though I specify failonerror = true in 
the exec tag.

Anyone else seen this?


James Jarvis wrote:

>I get an OutOfMemoryError when I try running the javadoc task on a large
>amount of files (~750).  I am running java 1.4.0 on Linux.  I have also
>tried changing the memory settings, but I still get the same error.  It
>also says "BUILD SUCCESSFUL" when it obviously was not.
>Has anyone encountered this problem?  I did not see it in the FAQ or bug
>To unsubscribe, e-mail:   <>
>For additional commands, e-mail: <>

Colin Truesdale
Causeway Support, Aepona Ltd

Tel 	: +44 (0)2890 275 232
Mob 	: +44 (0)7766 477 990
Email	:
Causeway Support HelpDesk: +44 (0)2890 275 275
Privacy & Confidentiality Notice:
The information contained in this electronic mail message is intended for
the named recipient(s) only. It may contain privileged and / or confidential
information.  If you are not an intended recipient, you must not copy,
forward, distribute, or take any action in reliance on it.  If you have
received this electronic mail message in error please notify the sender
immediately.   Thank you.

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message