ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sören Edzen" <soren.ed...@frontec.se>
Subject Ant install, deploy target -> Tomcat4 failure
Date Mon, 25 Nov 2002 10:27:06 GMT
Hi!
Before I go into my problem this is my environment:
Redhat Linux 7.1 on a PII 233 MHz with 256MB Ram
Tomcat4 version 4.1.12
Ant version 1.5.1
But the problem described below also appears on Redhat 8.0 and FreeBSD 4.5,
4.7

I'm trying to use ant to install and deploy JSP/servelt apploction to a
Tomcat4.12 server. But when I try theese two ant tasks I get the following
error:

BUILD FAILED
file:/home/soredz/Projects/ch04/build.xml:241: Directory
/var/tomcat4/webapps/ch04 creation was not successful for an unknown reason

Somehow ant seems unable to create and copy the files to the
${catalina.home}/webbapps directory. The line 241 in build.xml is as
follows:
	    <mkdir     dir="${deploy.home}"/>

If I try to use Tomcat4 manager to install it via the address field as
follows:
	http://localhost:8080//manager/install?path=/ch04
war=file:/home/soredz/Projects/ch04/build
I get the following error msg:
FAIL - Encountered exception java.io.IOException:
java.lang.IllegalArgumentException: Document base
/home/soredz/Projects/ch04/build does not exist or is not a readable
directory

But if I copy the build dir to /tmp/build and issu the following:
	http://localhost:8080//manager/install?path=/ch04 war=file:/tmp/build
it works. But it's the same user, group and chmod in both places.

I have setup the correct user and password in tomcat-user.xml

Does anybody know the solution to this problem? 
If you need more information from me, let me know and i'll supply it.




--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message