ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Acton <dac...@cs.uct.ac.za>
Subject Re: CVS checkout problem
Date Thu, 10 Oct 2002 08:54:31 GMT

Hi Thomas

It seems a little silly to me that this problem exists, and I'm not sure
_why_ it exists, but I have figured out a waya round it. The error code 2  
you're getting seems to correspond to a "file not found error" [1]. 

So download a cvs executable, and put it in your path. Then when you run
ant from the commandline, and it tries to perform a <cvs> task, it'll
work, using the cvs.exe in your path.

Hope it helps
Daniel

[1] - <bash>$ perror 2
      Error code   2:  No such file or directory


On Thu, 10 Oct 2002, Thomas Saxtoft wrote:

> Using an old script that used to work, I now find my self with a
> problem. I can't checkout from cvs. I get this error message:
> 	[cvs] Caught exception: CreateProcess: cvs
> -d:pserver:builder@192.9.214.17 	2:/home/CVSHOME checkout dk
> error=2
> 
> If I run the cvs command (cvs
> -d:pserver:builder@192.9.214.172:/home/CVSHOME checkout dk) then it
> works fine. When I run ant with -debug then project base dir and
> everything looks fine. My script also starts making the .cvspass file
> without problems.
> 
> Thank you,
> 
> Thomas Saxtoft
> 
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
> 
> 


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message