ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dushyant Shrivastava" <dus...@yambay.com>
Subject RE: MAIL task
Date Sun, 27 Oct 2002 23:59:43 GMT
Hi Jeff,
Thanks for the reply mate! Yes I did finally resolve this issue but by backtracking to ANT
1.4.1 and JDK 1.4.1 ! Still not sure what the problem was with ANT 1.5 and JDK 1.4.1 But our
team is insistent on using ANT 1.4.1 so I did not bother to investigate more.
Thanks again
Dushy

-----Original Message-----
From: Jeff Johnson [mailto:jeff.johnson@digeo.com]
Sent: Saturday, October 26, 2002 1:37 AM
To: Ant Users List
Subject: RE: MAIL task


Dushyant,

Did you ever resolve this issue?

I'm doing the same thing using Ant 1.5.1 and JDK 1.4.1_01, and it works correctly for me.
 The email body is in HTML format.  I've also tested it against Ant 1.5, and it works.

        <zip destfile="${test.dir}/reports/test-report.zip"
             basedir="${test.dir}/reports/html" />

        <mail mailhost="mail.digeo.com"
              from="NightlyBuild-Test@digeo.com"
              toList="jeff.johnson@digeo.com"
              subject="NightlyBuild test results [${TODAY}]"
              messagefile="${test.dir}/reports/html/overview-summary.html"
              messagemimetype="text/html">
            <fileset dir="${test.dir}/reports">
                <include name="test-report.zip"/>
            </fileset>
        </mail>

- Jeff


-----Original Message-----
From: Dushyant Shrivastava [mailto:dushys@yambay.com]
Sent: Wednesday, October 23, 2002 12:24 AM
To: Ant Users List
Subject: MAIL task


Hi guys,
I am using ANT 1.5 with JBoss 3.0.2, JDK 1.4.1.

This is my code which basically should send the mail out:
<!-- =================================================================== -->
<!-- Send mail out                                                                    
  -->
<!-- =================================================================== -->

<target name="mail" depends="compile, test">

<mail mailhost="pluto" subject="Test build results" messagemimetype="text/html" messagefile="${reports}/overview-summary.html"
>
          <from address="dushys@yambay.com"/>
          <to address="dushys@yambay.com"/>
           <fileset dir="${reports}">
                           <include name="index.html"/>
                </fileset>     
        </mail>
</target>

This is what my JUnitreport task looks like:


 </junit>
        <junitreport todir="${reports}">
          <fileset dir="${reports}">
             <include name="TEST-*.xml"/>
          </fileset>
          <report format="noframes" todir="${reports}"/>
       </junitreport> 

Now every time the mail is sent out, it gets to my address in plain text instead of the html
format!! Has anyone come across this problem, is this a problem with ANT 1.5 in particular???

 

Any help is much appreciated

Thanks

Dushy

 


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message