ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dushyant Shrivastava" <dus...@yambay.com>
Subject MAIL task
Date Wed, 23 Oct 2002 07:23:50 GMT
Hi guys,
I am using ANT 1.5 with JBoss 3.0.2, JDK 1.4.1.

This is my code which basically should send the mail out:
<!-- =================================================================== -->
<!-- Send mail out                                                                    
  -->
<!-- =================================================================== -->

<target name="mail" depends="compile, test">

<mail mailhost="pluto" subject="Test build results" messagemimetype="text/html" messagefile="${reports}/overview-summary.html"
>
          <from address="dushys@yambay.com"/>
          <to address="dushys@yambay.com"/>
           <fileset dir="${reports}">
                           <include name="index.html"/>
                </fileset>     
        </mail>
</target>

This is what my JUnitreport task looks like:


 </junit>
        <junitreport todir="${reports}">
          <fileset dir="${reports}">
             <include name="TEST-*.xml"/>
          </fileset>
          <report format="noframes" todir="${reports}"/>
       </junitreport> 

Now every time the mail is sent out, it gets to my address in plain text instead of the html
format!! Has anyone come across this problem, is this a problem with ANT 1.5 in particular???

 

Any help is much appreciated

Thanks

Dushy

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message