ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From neha.ve...@autodesk.com
Subject Starting WebLogic
Date Thu, 10 Oct 2002 18:43:19 GMT
Hi all,
Trying to start Weblogic -- starting is not the problem but ant just stops after weblogic
is started.
Tried running start.weblogic in parallel -- but no luck with that either -- WebLogic does
start but ant never resumes the remaining tasks.
Any help on this would be much appreciated -- also has anyone tried starting WebLogic as a
Service ??
Thanks,
Neha Verma
<target name="start.weblogic">
	<parallel>
		<java classname="weblogic.Server" fork="yes"
				    dir="/bea/user_projects/mydomain">

		 <classpath>
			<pathelement location="/bea/weblogic700/server/lib/weblogic.sp.jar"/>
			 <pathelement location="/bea/weblogic700/server/lib/weblogic.jar"/>
			 <pathelement location="$/bea/j2sdkee1.3.1/lib/junit.jar"/>
		</classpath>

		<jvmarg value="-hotspot"/>
		<jvmarg value="-ms64m"/>
		<jvmarg value="-mx64m"/>
		<jvmarg value="-Djava.library.path=$/bea/jdk131_02/lib;/bea/weblogic700/server/bin"/>
		<jvmarg value="-Dweblogic.Name=myserver"/>
		<jvmarg value="-Dbea.home=$/bea"/>
		<jvmarg value="-Dweblogic.management.username=user"/>
		<jvmarg value="-Dweblogic.management.password=pwd"/>
		<jvmarg value="-Djava.security.policy==./server/lib/weblogic.policy"/>

		</java>
	<sequential>
		<waitfor maxwait="1" maxwaitunit="minute">
			<http url="http://localhost/console"/>
		</waitfor>
	</sequential>
	</parallel>
</target>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message