ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gavin Simpson <gsimp...@superscape.com>
Subject Starteam <stlabel> Exception
Date Wed, 30 Oct 2002 14:57:35 GMT
Hi, I'm having a problem adding a label to my project within starteam as it
causes the following exception:

A view can only be modified from its current configuration.
        at
com.starbase.starteam.vts.comm.BinaryCommand.popException(BinaryCommand.java
:643)
        at com.starbase.starteam.vts.comm.Command.pop(Command.java:303)
        at
com.starbase.starteam.vts.comm.BinaryCommand.readInt(BinaryCommand.java:183)
        at
com.starbase.starteam.LabelRWImpl.readGutsForCreation(LabelRWImpl.java:35)
        at com.starbase.starteam.CmdCreateLabel.pop(CmdCreateLabel.java:32)
        at
com.starbase.starteam.vts.comm.CommandMacro.execute(CommandMacro.java:107)
        at
com.starbase.starteam.PutMethods$3.createNewLabel(PutMethods.java:148)
        at com.starbase.starteam.PutMethods$3.execute(PutMethods.java:103)
        at com.starbase.starteam.PutMethods.put(PutMethods.java:509)
        at com.starbase.starteam.PutMethods.put(PutMethods.java:503)
        at com.starbase.starteam.Server.putItems(Server.java:440)
        at com.starbase.starteam.Label.update(Label.java:548)
        at
org.apache.tools.ant.taskdefs.optional.starteam.StarTeamLabel.execute(StarTe
amLabel.java:145)
        at org.apache.tools.ant.Task.perform(Task.java:317)
        at org.apache.tools.ant.Target.execute(Target.java:309)
        at org.apache.tools.ant.Target.performTasks(Target.java:334)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1250)
        at org.apache.tools.ant.Main.runBuild(Main.java:610)
        at org.apache.tools.ant.Main.start(Main.java:196)
        at org.apache.tools.ant.Main.main(Main.java:235)

Using the following ant:

    <target name="labelsource">
        <tstamp>
            <format property="sourcestamp" pattern="yyyyMMddHHmmss"
locale="en"/>
        </tstamp>
        <stlabel 
            description="autogenerated label for build number
${build.number} on ${sourcestamp}" 
            label="AutoBuild_Source_${build.number}"  
            lastbuild="${sourcestamp}" 
            username="username" 
            password="password" 
            servername="Server-StarTeam" 
            serverport="1024" 
            projectname="TestProject" 
            viewname="TestProject"/>
    </target>


I can apply labels through the starteam gui and stcmd command line call thus
the connection to the server seems to be fine.

Also I'm able to check in and check out using <stcheckin> and <stcheckout>

Using the -debug option on the command line sheds no light on the problem.

Any light shed on this would be greatly appreciated.

Cheers,
Gavin Simpson.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message