ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerome Lacoste @ BBC" <lacostej...@altern.org>
Subject Re: Possible bug with copy in Ant 1.5
Date Fri, 18 Oct 2002 08:59:49 GMT
Stefan Bodewig wrote:

>On Mon, 14 Oct 2002, Jerome Lacoste <lacostejbbc@altern.org> wrote:
>
>  
>
>>Non-existent file last modified: 0
>>    
>>
>
>In that case I don't really see how the current code can assume an
>non-existing file to be up-to-date.  There is no real difference
>between the code here and the one that gets called for the fileset
>case (except that the later explicitly checks for destFile.exists and
>adds two seconds on the value of "now" on Windows).
>
>I'm going to put an explicit check into <copy>, could you please try
>the next nightly build (20021015) and see whether the problem
>persists?
>
Stephan,

I've downloaded the new build, but I am unable to reproduce the problem 
with the former version of the file.
Now it copies correctly. Don't know what changed.

One thing: I've changed IDE in the meantime. I was using netbeans and I 
know NetBeans often locks files in such a way that other applications 
(the explorer or our RCS tool) can't access them correctly. The problem 
could have been related.

If the problems comes again, I will let you know.

Cheers,

Jerome


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message