ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David McTavish <dmctav...@SANDVINE.com>
Subject ant1.5 and jdk1.3.1
Date Wed, 18 Sep 2002 14:09:36 GMT

Here's my problem. Our build scripts worked perfectly yesterday when we were
running on JDK1.4 with Ant1.5. Now, we have to roll back to jdk1.3.1 so that
our app can run on FreeBSD. No problem, we've rolled back the code base so
we're not using any JDK1.4 goodies, and everything should be fine and dandy.
Unfortunately not so... now, when I run the compile target of my build
script I get the following error:

compile.impl:
    [javac] Compiling 20 source files to
M:\dmctavish_jdk13\sw\application\util\
classes

BUILD FAILED
java.lang.UnsupportedClassVersionError: com/sun/tools/javac/Main
(Unsupported ma
jor.minor version 48.0)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:488)
        at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:106)


I've truncated it as you get the idea.
This chokes on the very first file it attempts to compile. Any ideas would
be greatly appreciated.

d.

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message