ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David McTavish <dmctav...@SANDVINE.com>
Subject Access is denied
Date Thu, 05 Sep 2002 18:43:59 GMT


Has anybody else experienced this message when trying to copy a jar file
that has just recently been built? It's an on-again, off-again problem that
always happens at about the same file, but doesn't happen every time.
Basically, all I'm doing is doing an <ant> to another folder to compile and
build dependency code, and then copy the resulting jar file to the local
package lib directory.

sample ant script:

project/build.xml
<target name="test description="Access is denied.">
    <ant dir="../util" target="build" />
    <copy toDir="lib" file="../util/build/util.jar" />
</target>


util/build.xml
<target name="compile" description="">
        <javac srcdir="${src.dir}"
               destdir="${target.dir}/${compile.dir}"
               debug="on"
               classpathref="build.classpath"
               deprecation="yes" />
</target>

<target name="build" depends="compile" description="">
        <jar compress="true"
             jarfile="${target.dir}/${build.dir}/${build.archive}"
             basedir="${target.dir}/${compile.dir}">
            <metainf dir="${src.dir}/META-INF" />
            <include name="com/sandvine/util/**/*.class" />
        </jar>
</target>

Also, if you try to manually copy the file using cp or copy, it always
works, even though its seconds after the fact.


Environment:
OS: Win2K using Cygwin Bash
Ant version 1.50 (July 9/02)

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message