ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <jakarta-...@ehatchersolutions.com>
Subject Re: Ant 1.5 and Intellij/IDEA
Date Fri, 13 Sep 2002 15:39:24 GMT
Gordon Tyler wrote:
> Erik Hatcher wrote:
> 
>> To use Ant 1.5 I just copy in ant.jar and optional.jar to IDEA's lib 
>> directory and Ant 1.5 is then "installed".
> 
> 
> The current EAP versions of IDEA already have Ant 1.5, if I'm not mistaken.

I'm running build 638, but also I'm using a CVS HEAD build of Ant 
(version 1.6alpha), so I need to copy the files in.  I require the 
'file' attribute addition I made to <fileset> for my builds.


>> As for double-clicking build errors - I have mixed results with that. 
>> Sometimes it works for me, other times it does not.  I still have not 
> 
> 
> I've never had a problem with that in the EAP builds. Perhaps it is 
> buggy in the 2.6 version?

Again, I'm running a pretty recent (although not latest) EAP.


> Again, I've never had problems with this. I just make sure that my Ant 
> build works correctly from commandline and then I adjust my IDEA 
> project's list of jars so that it's syntax checking and indexing stuff 
> works. I never actually use IDEA's build system. I always use an Ant 
> target. I have my two main targets assigned to keyboard shortcuts (I 
> think this is new in the EAP builds, not available in 2.6).

I have not spent a great deal of time working on this because what we 
have works, but there are still some unresolved issues in my IDEA 
environment that I'd like to troubleshoot at some point in the near 
future.  It could be my fault for putting some conflicting libraries in 
IDEA's lib directory, or some weirdness in IDEA.

	Erik



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message