ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert J. Clark" <cl...@sitraka.com>
Subject Re: building 1.5 on solaris 9
Date Tue, 24 Sep 2002 20:31:54 GMT
On Tue, 24 Sep 2002 14:16:12 -0600
"Jonathan Ellis" <jbellis@hotmail.com> wrote:

> what I've done so far:
> 
> setenv JAVA_HOME /  #(java/javac/etc. are in /bin/)
> setenv CLASSPATH /usr/j2se/lib/tools.jar


> BUILD FAILED
> file:/usr/share/src/jakarta-ant-1.5/build.xml:468:
> java.lang.UnsupportedClassVersionError: sun/tools/native2ascii/Main
> (Unsupported major.minor version 48.0)

> java -version says
> java version "1.3.1"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1-b24)
> Java HotSpot(TM) Client VM (build 1.3.1-b24, mixed mode)

Looks like your tools.jar is from a 1.4 JDK. This cannot be used with
a 1.3 or earlier VM (the class version changed).

Try finding a 1.3 tools.jar and use that instead.

- Rob

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message