ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re[2]: Can't get linkoffline to work with <javadoc> task
Date Fri, 27 Sep 2002 19:32:51 GMT
Hello joel,

Are you sure that the URL's that point to the classes in the Java API
are valid when you do this?

In my build.properties file, I set the following:

javadoc.jdk.offline=true
javadoc.jdk.packagelistLoc=C:/j2sdk1.4.1/docs/api/

  note that I tried the above packagelistLoc with and without the
  trailing slash with no difference observed.  I also tried a
  file:///.... URL and tried doing .../api/package-list, both of which
  resulted in no links created at all.

I have the following set up to run in Javadoc...

<link offline="${javadoc.jdk.offline}" href="${javadoc.jdk.href}" packagelistLoc="${javadoc.jdk.packagelistLoc}"
/>

I echoed the values for the above values.  They are...

<echo message="${javadoc.jdk.offline}"/>
<echo message="${javadoc.jdk.href}"/>
<echo message="${javadoc.jdk.packagelistLoc}"/>

[echo] true
[echo] http://java.sun.com/j2se/1.4/docs/api/
[echo] C:/j2sdk1.4.1/docs/api/


However, the result of the link to the Object class from the javadoc
of one of my classes ends up being this:

file:///D:/myclasses/repository/enhydra/Barracuda_2002-09-23/Barracuda/javadocs/http://java.sun.com/j2se/1.4/docs/api/java/lang/Object.html


That URL is totally invalid.  How did you set things up to get valid
URL's generated pointing to the offline location of your jdk docs????


Jake

Friday, September 27, 2002, 3:39:39 AM, you wrote:

jf> Hi Jacob and All,

jf> I finally found where was my mistake, but I believe this revealed a possible RFE for
Ant <javadoc> task in order to help diagnose such mistakes:

jf> What happened was that my packagelistLoc path was simply wrong. The problem with Ant
<javadoc> task is that apparently in such a case it silently ignore the links option
and DOES NOT PASS IT to
jf> javadoc itself (as shown by ant -verbose). So I got no error message.

jf> I discovered the problem by invoking directly javadoc itself, in order to check if
as you suggested javadoc was broken. It is not broken: at the first invocation I immediatly
got an error
jf> message: "Error reading /my/wrong/path/to/package-list". I fixed the path and everything
worked fine!

jf> Could it be and RFE to improve Ant <javadoc> task error reporting in such a case?

jf> Thanks,
jf> Joel


jf> Jacob Kjome wrote:
>> 
>> Hello joel,
>> 
>> I believe this is broken in javadoc itself.  If it worked there, it
>> would work in Ant.  Read the release notes for j2sdk1.4.1.  There is a
>> reference to a bug about that.
>> 
>> Jake
>> 
>> Thursday, September 26, 2002, 11:14:02 AM, you wrote:
>> 
>> jf> Hi,
>> 
>> jf> I use the javadoc task in my project. It works fine except that I can't get
the linkoffline option
>> jf> to work.
>> 
>> jf> I tried using the linkoffline attribute of the <javadoc> task like this:
>> jf> <javadoc [...] linkoffline="${link.javadoc.url.j2se} ${link.javadoc.packagelist.j2se}"
>
>> 
>> jf> And I also tried the <link> nested element like this:
>> jf> <link offline="true" href="${link.javadoc.url.j2se}"
>> jf> packagelistloc="${link.javadoc.packagelist.j2se}" />
>> 
>> jf> But in both case, when I run ant (with the -verbose option to see what gets
actually passed to
>> jf> javadoc), the -linkoffline option is not present in the actual call to javadoc.
>> 
>> jf> I searched the ant-user list and did not see any mention of this problem.
Am I missing something?
>> 
>> jf> Thanks,
>> jf> Joel
>> 
>> --
>> Best regards,
>>  Jacob                            mailto:hoju@visi.com




-- 
Best regards,
 Jacob                            mailto:hoju@visi.com


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message