ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lyndon Samson <sam...@ozemail.com.au>
Subject Re[2]: Telnet and tar -xvf
Date Fri, 13 Sep 2002 05:54:51 GMT
Hello Julia,

Have you tried putting all the commands in one shell script and just
using the telnet task to execute that script?

This might help in diagnosing the problem.

cheers
lyndon


Thursday, September 12, 2002, 7:32:15 AM, you wrote:

VJ> Here is a snippet (the tar actually executes in the middle of the sequence):

VJ> <telnet server="${server.name}" timeout="60">
VJ>      <read>ogin: </read>
VJ>      <write echo="false" string="${accutrack.user}"></write>
VJ>      <read>assword:</read>
VJ>      <write echo="false" string="${accutrack.pass}"></write>
VJ>      <read string=">"></read>
VJ>      <write string="cd ${accutrack.home}/${accutrack.applications}"/>
VJ>      <read timeout="300" string=">"></read>
VJ>      <write string="tar -xvf accutrack.war"/>
VJ>      <read timeout="600" string=">"></read>
VJ>      <write string="test.sh"/>
VJ>      <read timeout="300" string=">"></read>
VJ>      ...
VJ> </telnet>

VJ> When I nohup the tar through ant and tail nohup.out, I don't see the results
VJ> of the extraction. However, if I telnet into the box and tail nohup.out, I
VJ> see the results. Why would that be?

VJ> Julia

VJ> -----Original Message-----
VJ> From: Steve Loughran [mailto:steve_l@iseran.com]
VJ> Sent: Wednesday, September 11, 2002 3:48 PM
VJ> To: Ant Users List
VJ> Subject: Re: Telnet and tar -xvf



VJ> ----- Original Message -----
VJ> From: "Vaughn, Julia" <Julia.Vaughn@cingular.com>
VJ> To: "'Ant Users List'" <ant-user@jakarta.apache.org>
VJ> Sent: Wednesday, September 11, 2002 11:32 AM
VJ> Subject: RE: Telnet and tar -xvf


>> I have tried that as well as unzip -of. I believe it's a bug in the telnet
>> task. I am responsible for automating ~20 java apps (build and deployment)
>> and I see similar things with every build file. If I nohup the tar and
VJ> sleep
>> 60, then it works fine. Has anyone else experienced this?

VJ> I usually remote deploy by using jar -xvf, never hit problems. But I do set
VJ> the prompt at the far end.

VJ> Are you making sure that you wait for a response after making the tar call?
VJ> the nohup hints implies you need to keep it running after the task
VJ> exits...if there isnt a <read> at the end the task exits without waiting for
VJ> tar to finish.


VJ> --
VJ> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
VJ> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

VJ> --
VJ> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
VJ> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>



-- 
Best regards,
 Lyndon                            mailto:samson@ozemail.com.au


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message