ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain ROUVOY <romain.rou...@lifl.fr>
Subject Re: inheritrefs doesn't work
Date Thu, 19 Sep 2002 15:23:29 GMT
Hello,

   I actually have the same problem with the inheritRefs option. The
option work on the first and second call but not on the third one and I
don't understand why ! =(

Regards,
Romain

Le jeu 19/09/2002 à 17:20, Jacob Kjome a écrit :
> Hello Daniel,
> 
> I am having the same issue with the <ant ...> task and posted, then
> reposted with no response.
> 
> Anyone know what is going on with inheritRefs?
> 
> Jake
> 
> Thursday, September 19, 2002, 9:25:18 AM, you wrote:
> 
> ADC> I can not get inheritRefs to work properly.
> 
> ADC> Code fragments:
> 
> ADC>         <target name="init" description="Sets up a file set of the axis jar
files">
> ADC>                 <path id="allJars">
> ADC>                         <fileset dir="/foo2" id="bJars">
> ADC>                                 <include name="....."/>
> ADC>                         </fileset>
> ADC>                         <fileset dir="/foo" id="aJars">
> ADC>                                 <include name="....."/>
> ADC>                         </fileset>
> ADC>                         <fileset dir="/" id="cJars">
> ADC>                                 <include name="....."/>
> ADC>                         </fileset>
> ADC>                 </path>
> ADC>         </target>
> 
> ADC>         <target name="genWsdlTarget">
> ADC>                 <java classname="${wsdl.java2wsdl}" fork="true">
> ADC>                         <classpath>
> ADC>                                 <fileset refid="axisJars"/>
> ADC>                         </classpath>
> ADC>                 </java>
> ADC>         </target>
> 
> 
> ADC>         <target name="genWsdl" description="Generate wsdl from compiled java"
depends="init">
> ADC>                 <antcall inheritrefs="true" target="genWsdlTarget">
> ADC>                         <param name="wsdlTarget" value="...."/>
> ADC>                 </antcall>
> ADC>         </target>
> 
> 
> 
> ADC> BUILD FAILED
> ADC> file:build.xml:166: No directory specified for fileset.
> 
> ADC> Line 166 corresponds to the <java> tag.  Can someone help me out here?
 What am I missing?  Or is there a bug?
> 
> ADC> ant -version
> ADC> Apache Ant version 1.5 compiled on July 12 2002
> 
> 
> ADC> Thanks, 
> ADC> Dan
> 
> ADC> --
> ADC> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> ADC> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
> 
> 
> 
> -- 
> Best regards,
>  Jacob                            mailto:hoju@visi.com
> 
> 
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message