ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoff Meakin" <geo...@isocra.com>
Subject RE: Exec error from time to time on Linux
Date Fri, 09 Aug 2002 17:05:29 GMT
Well you can always run ant -debug to find out whats *really* going on

In general though when I get these codes its a good thing.. 
I usually get the number 15623, but figure the executed program is
returning some type of success code...

ant -debug will provide all the output from .sh which will probably
show you whats going wrong on the day its failing.

-Geoff



-----Original Message-----
From: Vincent Massol [mailto:vmassol@octo.com]
Sent: 09 August 2002 05:25 PM
To: ant-user@jakarta.apache.org
Subject: Exec error from time to time on Linux


Hi,

>>From time to time I get the following error on a Linux machine : 

"exec returned: 143"

The faulty code in build.xml is :

<exec os="Linux" executable="sh" failonerror="true">
    <arg line="work/deliver-local.sh"/>
</exec>

Actually this error happens at various places in my build.xml but always
when doing an <exec>. One day it is one, another day it is at another
place ...

The worse is that it can run 2 days with no error and then will fail 3
times in a row.

I am a bit stuck to diagnosis the problem. Would any of you have any
idea ?

Thanks a lot
-Vincent


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message