ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wannheden, Knut" <knut.wannhe...@paranor.ch>
Subject RE: Problem with default values
Date Tue, 06 Aug 2002 14:02:53 GMT
try swapping your last line for:

	<property file="${my_prop_file}"/>

the value of my_prop_file already includes the whole path the way you
defined it.

--
knut

> -----Original Message-----
> From: Christian Holmqvist, IT, Posten
> [mailto:christian.holmqvist@posten.se]
> Sent: Dienstag, 6. August 2002 15:58
> To: 'Ant Users List'
> Subject: Problem with default values
> 
> 
> Hi
> 
> I have a small problem...
> 
> I want to be able to change some values in a property file 
> and use the name
> of the file as input parameter to the ant script. But when no input
> parameter is submitted I want default values to be used, also 
> they in a
> property file.
> 
> I been trying to do something like this:
>   <property name="EllaRootBaseDir" value="${basedir}/.."/>
>   <property name="my_prop_file"
> value="${EllaRootBaseDir}/default.properties"/>
>   <property file="${EllaRootBaseDir}/${my_prop_file}"/>
> 
> But this don't work since the last property task gets totally strange
> values.... (something liked d:\something\d:something\ )
> 
> Can someone help me?
> 
> /Christian Holmqvist
> 
> --
> To unsubscribe, e-mail:   
<mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message