ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Schewe <jpsch...@mtu.net>
Subject Re: Ant doesn't do paths right under windows
Date Sat, 03 Aug 2002 01:23:05 GMT
Once I removed the quotes it worked.  Thanks.  

On Fri, Aug 02, 2002 at 07:53:17PM -0400, Erik Hatcher wrote:
> Could you please provide your build file segment of <javac>?
> 
> The quotes are obviously part of the issue, and should be removed from 
> your property setting, but I'm guessing you have another issue that 
> needs addressing.
> 
> 	Erik
> 
> Jon Schewe wrote:
> >I'm trying to get ant to work right under windows, or cygwin for that 
> >matter.
> >I've got the patched ant script for cygwin, doesn't help.
> >
> >Here's the problem, I've got a property defined that's an absolute path:
> >catalina.home="c:/packages/Apache-Tomcat-4.0"
> >
> >When I build under cygwin I get:
> >jschewe@MN65-EGGPLANT:~/projects/fll/code/2002/implementation
> >
> >>ant compile
> >
> >Buildfile: build.xml
> >
> >prepare:
> >
> >compile:
> >    [javac] Compiling 6 source files to
> >\\mn65-fs1\home\jschewe\projects\fll\code\2002\implementation\build\WEB-INF\classes
> >
> >BUILD FAILED
> >file://mn65-fs1/home/jschewe/projects/fll/code/2002/implementation/build.xml:213:
> >\\mn65-fs1\home\jschewe\projects\fll\code\2002\implementation\"c:\packages\Apache-Tomcat-4.0"\common\lib
> >not found.
> >
> >Total time: 6 seconds
> >
> >When I build under windows (windows 2000 CMD.exe) I get:
> >H:\projects\fll\code\2002\implementation>\\zeppo\export\packages\java\ant\1.5\bin\ant
> >compile
> >\\zeppo\export\packages\java\ant\1.5\bin\ant compile
> >Buildfile: build.xml
> >
> >prepare:
> >
> >compile:
> >    [javac] Compiling 6 source files to
> >H:\projects\fll\code\2002\implementation\build\WEB-INF\classes
> >
> >BUILD FAILED
> >file:H:/projects/fll/code/2002/implementation/build.xml:213:
> >H:\projects\fll\code\2002\implementation\"c:\packages\Apache-Tomcat-4.0"\common\lib
> >not found.
> >
> >Total time: 6 seconds
> >
> >Does someone know how to fix this?  It basically means I can't use ant for 
> >my
> >JSP development under windows.
> >
> 
> 
> 
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

-- 
Jon Schewe | http://mtu.net/~jpschewe | jpschewe@mtu.net
For I am convinced that neither death nor life, neither angels 
nor demons, neither the present nor the future, nor any 
powers, neither height nor depth, nor anything else in all 
creation, will be able to separate us from the love of God that 
is in Christ Jesus our Lord. - Romans 8:38-39

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message