ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran" <stev...@iseran.com>
Subject Re: build xml?
Date Thu, 29 Aug 2002 16:35:08 GMT

----- Original Message -----
From: "Shatzer, Larry" <Larry.Shatzer@Spirent.com>
To: "'Ant Users List'" <ant-user@jakarta.apache.org>
Sent: Thursday, August 29, 2002 8:33 AM
Subject: RE: build xml?


> I thought -f might have been an alias for -find... since that is the only
> option that started with f...
>
> Might be a good time to document them :)

the -f is there for compatibility with make, as in make -f somemakefile

It'd be nice if we also had -Dproperty mapped to -Dproperty=true as I
sporadically get burned by that

>
> -- Larry
>
> > -----Original Message-----
> > From: Brian Schantz [mailto:bschantz@galileolabs.com]
> > Sent: Thursday, August 29, 2002 8:31 AM
> > To: 'Ant Users List'
> > Subject: RE: build xml?
> >
> >
> > Just to be clear, '-f' and '-file' are synonyms for
> > '-buildfile'. Since they
> > don't seem to be documented (outside the source) you should
> > use them at your
> > own risk.
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Brian Schantz [mailto:bschantz@galileolabs.com]
> > > Sent: Thursday, August 29, 2002 8:13 AM
> > > To: 'Ant Users List'
> > > Subject: RE: build xml?
> > >
> > >
> > > If it doesn't exist in your current directory (where ant will
> > > find it)
> > > use
> > > ant -f <path to xml file including filename>
> > >
> > >
> > >
> > > > -----Original Message-----
> > > > From: Brian Egger [mailto:brian.egger@state.de.us]
> > > > Sent: Thursday, August 29, 2002 8:05 AM
> > > > To: ant-user@jakarta.apache.org
> > > > Subject: build xml?
> > > >
> > > >
> > > > Ok I suppose this is probably a frequent newbie question.
> > > > Which I am a newbie to ant, but I try to run Ant on Win 2000.
> > > > I have the classpath set for the ant.jar and I also have it
> > > > set for the xml-xxxx.jar. Ant I have the path and all of the
> > > > enviroment variables set to the correct paths. But when I go
> > > > to run ant, I receive an error upon entering the command
> > > > "Buildfile: build.xml does not exist; Bulid Failed" Where
> > > > should I put the xml file or what am I missing here.
> > > >
> > > > btw, I did STFW and RTFM, but I saw no refernece to the bulid.xml
> > > >
> > > > thanks
> > > > Brian Egger ,
> > > > brian.egger@state.de.us
> > > >
> > >
> > > --
> > > To unsubscribe, e-mail:
> > <mailto:ant-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> > <mailto:ant-user-help@jakarta.apache.org>
> >
> > --
> > To unsubscribe, e-mail:
> > <mailto:ant-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> > <mailto:ant-user-help@jakarta.apache.org>
> >
>
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message