ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Astor <epas...@comcast.net>
Subject Re: Error: Cannot use classic compiler
Date Thu, 15 Aug 2002 22:10:19 GMT
If anyone is having the below problem, I found the solution.
First, I was having this problem under 1.4.x and 1.3.x. This solution should
work under both:

Copy tools.jar from the /lib subdirectory of the jdk directory to the
/jre/lib/ext subdirectory of the jdk directory.

Nice and simple, a bit of a kludge, but it works!

Eric
----- Original Message -----
From: "Dirk V. Schesmer" <dirk.schesmer@t-online.de>
To: "Ant Users List" <ant-user@jakarta.apache.org>; "Eric Astor"
<epastor@comcast.net>
Sent: Thursday, August 15, 2002 4:33 PM
Subject: Re: Error: Cannot use classic compiler


> Eric,
> I have the same problem as you have when using Sun JDK 1.4.1 and Ant
> 1.4 or 1.5.
> When I use JSK1.3.x instead, it works! I posted the same question
> yesterday, but did not yet receive an answer.
>
> Dirk
>
> Eric Astor schrieb:
> > I'm trying to run my first build script under ant. The
> > error message that is returned is as follows:
> >
> > Cannot use classic compiler, as it is not available. A
> > common solution is to set the environment variable
> > JAVA_HOME to your jdk directory.
> >
> > I've verified that JAVA_HOME is set correctly, that the
> > ext directory of my JRE subdirectory under my jdk1.3.1_04
> > is empty, and that tools.jar is on both my classpath and
> > ant's generated classpath. Nothing seems to get rid of
> > this error. Any ideas?
> >
> > Thanks,
> > Eric Astor
> >
>
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message