ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Devienne <DDevie...@lgc.com>
Subject RE: Problems on Win2K with CVSChangeLog task when run under Sched uler
Date Fri, 19 Jul 2002 14:15:02 GMT
CVS.exe might not be in your PATH when run by the Task Scheduler. Try
extending the PATH in your script to find CVS.exe, and see if that makes any
difference. You could also run <available> before <cvschangelog> to assert
whether it's found, to fail more gracefully when it's not. --DD

-----Original Message-----
From: Dave Rathnow [mailto:dave.rathnow@wrx-ca.com] 
Sent: Thursday, July 18, 2002 7:11 PM
To: 'ant-user@jakarta.apache.org'
Subject: Problems on Win2K with CVSChangeLog task when run under Scheduler


I've been trying to get my Ant build script to run nightly using Window 2K's
Task Scheduler.  I can run the script from a command prompt so I'm
sure the script is fine.  

I've setup Task Scheduler to run the script through a batch file, which
also works at that command prompt, under my username, with the
working directory set to the directory of the ant script.
When it runs, it gets as far as CvsChangeLog and then blows:

CvsChangeLog:
[cvschangelog] ChangeLog command: [cvs log "-d >=2002-07-17"]
Execute:Java13CommandLauncher: Executing 'cvs' with arguments:
'log'
'-d >=2002-07-17'

The ' characters around the executable and arguments are
not part of the command.


BUILD FAILED
file:E:/Redevelopment/WMX/Projects/IPAnywhere/Utilities/BuildManager/Resourc
es/build.xml:122: Error running cvs log
	at
org.apache.tools.ant.taskdefs.cvslib.ChangeLogTask.execute(ChangeLogTask.jav
a:290)
	at org.apache.tools.ant.Task.perform(Task.java:317)
	at org.apache.tools.ant.Target.execute(Target.java:309)
	at org.apache.tools.ant.Target.performTasks(Target.java:334)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1250)
	at org.apache.tools.ant.Main.runBuild(Main.java:610)
	at org.apache.tools.ant.Main.start(Main.java:196)
	at org.apache.tools.ant.Main.main(Main.java:235)

Total time: 49 seconds

Anyone know what may be causing this?

Thanks,
Dave.

--
W. Dave Rathnow
Wireless Matrix Corporation 
Calgary, AB 
http://www.wirelessmatrixcorp.com
mailto:Dave.Rathnow@wrx-ca.com


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message