ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Devienne <DDevie...@lgc.com>
Subject RE: Resin on Mac OS X
Date Sat, 06 Jul 2002 22:52:58 GMT
Unfortunately, this is by design. <exec> waits for the child process to
complete. We may have a new <spawn> for Ant 1.6 for an equivalent of <exec>
that 'starts and forgets' child processes. I'm not sure it would work, but
have you tried to <exec> a shell script that does "httpd &"? The script
would complete, and ant would have the 'hand' back. --DD

-----Original Message-----
From: Gabriel Pack [mailto:grpack@yahoo.com]
Sent: Saturday, July 06, 2002 5:44 PM
To: ant-user@jakarta.apache.org
Subject: Resin on Mac OS X


I would like to have Ant start Resin as part of a
deployment process.

Previously, I was developing on Windows 2000. I had
Resin set up as an NT service. I used the exec task to
issue a "net start" command, and everything worked
fine. I've moved over to Mac OS X now, and the command
to start Resin as a daemon process is "httpd start".
When I issue this from a shell prompt, Resin spawns in
the background with no problems. If I try to exec the
command from within Ant, Resin starts; but it hangs
Ant, as if Resin isn't starting in the background. I
even tried exec on "httpd &", but Ant says that "&" is
illegal.

My software versions are Ant 1.4.1, JVM 1.3.1, Mac OS
X 10.1.5, and Resin 2.1.1.

Any insights would be appreciated.

__________________________________________________
Do You Yahoo!?
Sign up for SBC Yahoo! Dial - First Month Free
http://sbc.yahoo.com

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message