ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mastrorillo Laurence <Laurence.Mastrori...@medias.cnes.fr>
Subject Re: problem executing subproject with ant task
Date Wed, 24 Jul 2002 08:18:03 GMT
It's not the master build that defines the classpath and additionnal.path, as i
got several subproject, each one with its own additionnal path. When I run them
with their own build, it works fine, so i guess the classpath is not the
problem.
Anyway, I'll look further this direction.
Thanks
Laurence

Dominique Devienne a écrit :

> Salut ;-)
>
> Who defines the classpath and additional.path properties, and how?
>
> If it's the master build, you need to define 'inheritAll' and possibly also
> 'inheritRefs' (new to Ant 1.5) so the sub-build can see the properties.
>
> But I'm surprised you don't need these in the classpath to compile
> though!?!? In any case, one usually defines a <path id="cp"/> somewhere, and
> reference it in both <javac> and <java> using <classpath refid="cp"/>.
>
> Hope this helps, and re-post with more info if it's not the problem. --DD
>
> -----Original Message-----
> From: Mastrorillo Laurence [mailto:Laurence.Mastrorillo@medias.cnes.fr]
> Sent: Tuesday, July 23, 2002 7:47 AM
> To: ant-user@jakarta.apache.org
> Subject: problem executing subproject with ant task
>
> Hi All,
> using ant since 2 days, i have problem executing subproject with ant
> task.
> Here is my main build file :
>     <target name="compile">
>         <ant dir="${MF_OPER}" target="compile" />
>     </target>
>     <target name="execute" depends="compile">
>         <ant dir="${MF_OPER}" target="execute"/>
>     </target>
>
> and the subproject build file :
> <target name="compile" depends="clean">
>     <javac srcdir="${src}" destdir="${build}" deprecation="true" />
>   </target>
>   <!-- execution du programme -->
>   <target name="execute" depends="compile">
>     <java classname="${prog}" fork="true">
>       <arg value="${filesToRead}" />
>       <classpath>
>          <pathelement location="${build}"/>
>          <pathelement path="${classpath}"/>
>          <pathelement path="${additional.path}"/>
>       </classpath>
>     </java>
>   </target>
>
>     Here 's what i got in return :
>         execute:
>             [java] Java Result : 255
>
>     Note that "compile" works fine, and if i execute the subproject
> independently, it works to.
>     Can anyone help?
>     Thanks
>
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
>
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message