ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Blakey <...@blakey.org>
Subject Re: jar/zip tasks sometimes get NullPointerException
Date Wed, 17 Jul 2002 15:14:26 GMT
A couple of thoughts ...

1. Try this with a different VM - it might be a VM bug.

2. Do you have enough disk space?

3. Have you tried running jar standalone and seeing if you get the same error?

4. Have you tried checking out  the very latest 1.5 ant from the CVS 
repository and building it from source to see if it still has the same 
errors. With this in hand you also have a chance to debug it.




On Tuesday 16 July 2002 02:08 pm, you wrote:
> (The following problem does not occur with ant 1.4.1)
>
> Using ant 1.5, Windows 2000
> My build has been failing on the jar task (trace included below)
> I wish it failed every time I try to create a jar, but unfortunately this
> is not the case.
> It works when I try to create AAA.jar, but fails when I try to create
> BBB.jar.
> The only difference (that I can find) between these jar files, is the
> number of files/directories that I'm trying to put in them.
> The failures occur with large numbers of files. (it fails with 1800;  I
> haven't found the lower bound on #files that cause failure)
> Has anybody else noticed this?  I've seen a few postings to this list that
> discuss the same Exception, but I haven't found any discussion of number
> of files as a possible cause.
> Thanks for any insight...
> =======================
> BUILD FAILED
> java.lang.NullPointerException
>   at
> org.apache.tools.zip.ZipOutputStream.finish(ZipOutputStream.java(Compiled
> Code))
>   at
> java.util.zip.DeflaterOutputStream.close(DeflaterOutputStream.java:139)
>   at org.apache.tools.ant.taskdefs.Zip.execute(Zip.java:402)
>   (rest of stack omitted)

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message