ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diane Holt <hol...@yahoo.com>
Subject RE: Checking the version of Ant
Date Mon, 15 Jul 2002 16:11:15 GMT
--- Dominique Devienne <DDevienne@lgc.com> wrote:
> I'm sure there are other incompatible changes from Ant 1.4.1 to 1.5 that
> would make checking the required Ant version within Ant impossible. A
> coworker that tried to do that failed the same problem described here
> (but not because of <mail>).

Oops -- you're right, of course (I knew I should've waited until I'd had
some coffee before attacking my ant-* mail :) Okay, forget the other
suggestions, since clearly, they'll never even get reached -- but the
listener should still work, right?

(Of course, all of this version-mismatch-checking should actually be
unnecessary if you source-control your tools. If someone goes around that
and specifically pulls some other version, then they either know what
they're doing, or you should let them go ahead and get a confusing error
message so they can go ask someone who does :)

Diane

=====
(holtdl@yahoo.com)



__________________________________________________
Do You Yahoo!?
Yahoo! Autos - Get free new car price quotes
http://autos.yahoo.com

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message