ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diane Holt <hol...@yahoo.com>
Subject Re: Odd failure for 1.5Beta3 on Compaq Tru64 Unix
Date Thu, 04 Jul 2002 00:59:57 GMT
Are you in some kind of evil parallel universe? :)  The behaviour you get
is the exact opposite of what you should get (and I do). Ie., with
target's name set to "", and no args, I get the "Target `main'..." output,
etc.

What happens if you set 'default=""', when that's your target's name? What
happens if you capture the 'java' command line (up to the "n" in Main) and
execute it yourself?

I dunno, maybe I'm missing something obvious, but this one is a complete
puzzler to me. The only way you should get "Target `' doesn't exist..." is
if target == null, and I don't see how you could have a default specified
and end up with target being null. And, given Peter's change (which is
theoretically only temporarily in, so don't get too attached to it :), if
you don't have a default specified, but you do have a target named "main",
then that's what target should be set to, so again, not null. Are you up
for adding a little debug output to Project.java?  (I could do it, but
since things work for me, the output wouldn't be all that meaningful.)

Diane

=====
(holtdl@yahoo.com)



__________________________________________________
Do You Yahoo!?
Sign up for SBC Yahoo! Dial - First Month Free
http://sbc.yahoo.com

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message