ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Stopper" <mike.stop...@ams.com>
Subject Re: Specifying the version in the <manifest> task
Date Wed, 26 Jun 2002 14:48:11 GMT
Tenk you vedy much.

-----------------------------------------------------
Michael Stopper
Senior Principal / SPS Technical Architect
American Management Systems, Inc.
4114 Legato Road
Fairfax, Virginia  22033
703.227.6646 Office 
703.227.4696 FAX
mailto:Michael.Stopper@ams.com





Conor MacNeill <conor@cortexebusiness.com.au>
06/26/2002 10:34 AM
Please respond to "Ant Users List"

 
        To:     Ant Users List <ant-user@jakarta.apache.org>
        cc: 
        Subject:        Re: Specifying the version in the <manifest> task


Mike Stopper wrote:
> If I try to add a Manifest-Version attribute to a MANIFEST.MF file that 
> I'm creating from scratch, I basically wind up with two entries--one at 
> the top that says
> 
>         Manifest-Version: 1.0
> 
> and then later on mine shows up.  This results in an invalid MANIFEST 
> format, since you're only supposed to specify this tag once!!
> 

It's a bug. I have just committed a fix to the 1.5 branch.


> Is there any way to change the manifest version via the manifest task or 

> will it always provide this value for me??  It even looks like the 
> ordering of attributes, even though implied from the build script may be 

> (slightly) non-deterministic in the actual produced MANIFEST.MF file???
> 

In 1.5 the order will largely be as specified in the build file although 
some attributes, including the version and signature version must occur at 

the top.

Conor



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message