ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Gibbs" <dgi...@agency.com>
Subject java.lang.NoClassDefFoundError: org/apache/jasper/JspC
Date Mon, 24 Jun 2002 16:15:16 GMT
I hope some-one has solved this no-doubt simple problem,

I am trying to use the jspc optional task and get the following error.

"[java] java.lang.NoClassDefFoundError: org/apache/jasper/JspC
[java] Exception in thread "main"

I am using 1.5Beta3. I have the distributed "optional.jar" in the lib
directory. I have copied "jasper-runtime.jar" and "jasper-compiler.jar" to
the lib directory.

The LOCALCLASSPATH echoed from the ant.bat is as follows

"D:\jdk1.3.1_03\lib\tools.jar;D:\jakarta-ant-1.5Beta3\lib\xml-apis.jar;D:\ja
karta-ant-1.5Beta3\lib\xercesImpl.jar;D:\jakarta-ant-1.5Beta3\lib\optional.j
ar;D:\jakarta-ant-1.5Beta3\lib\jasper-runtime.jar;D:\jakarta-ant-1.5Beta3\li
b\jasper-compiler.jar;D:\jakarta-ant-1.5Beta3\lib\ant.jar;.;C:\Program
Files\Apache Group\Tomcat 4.1\common\endorsed\xercesImpl.jar;C:\Program
Files\Apache Group\Tomcat
4.1\common\endorsed\xmlParserAPIs.jar;D:\DB2\java\db2java.zip;D:\DB2\java\ru
ntime.zip;D:\DB2\java\sqlj.zip;D:\DB2\bin;C:\Documents and
Settings\dgibbs\My
Documents\work\shop_prototype\lib\j2ee.jar;D:\jakarta-log4j-1.2\dist\lib\log
4j-1.2.jar;"

There is some duplication in there because I have been trashing a bit
tragically at this problem.

Do y'all believe the error to be as reported  or could it be some further
dependency ? As a reality check I have been trying to run jspc.bat from the
tomcat 4.1 distribution and am getting a similarly inexplicable
NoClassDefFoundError for "org/xml/sax/SAXException". I'm a bit puzzled since
this class is distributed in "..\common\endorsed\xmlParserAPIs.jar".
Is it something to do with the uninitialised property
-Djava.endorsed.dirs="%JAVA_ENDORSED_DIRS%"
which I find in the jasper.bat file ? I'm not sure about the meaning if the
"endorsed directories".

I'd be very grateful if some-one who has worked through this could help.
btw.. JAVA_HOME, ANT_HOME, CATALINA_HOME, JASPER_HOME environment variables
all appear to be correctly set.

Dave


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message