ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alvarez, Gil" <...@pogo.com>
Subject RE: 1.5 installation question
Date Thu, 06 Jun 2002 22:12:01 GMT
Ok, here's the stack trace from -debug.
===========================================
BUILD FAILED
XML parser factory has not been configured correctly: Provider for javax.xml.parsers.SAXParserFactory
cannot be found
        at org.apache.tools.ant.util.JAXPUtils.newParserFactory(JAXPUtils.java)
        at org.apache.tools.ant.util.JAXPUtils.getParserFactory(JAXPUtils.java)
        at org.apache.tools.ant.util.JAXPUtils.newSAXParser(JAXPUtils.java)
        at org.apache.tools.ant.util.JAXPUtils.getXMLReader(JAXPUtils.java)
        at org.apache.tools.ant.helper.ProjectHelperImpl.parse(ProjectHelperImpl.java)
        at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java)
        at org.apache.tools.ant.Main.runBuild(Main.java)
        at org.apache.tools.ant.Main.start(Main.java)
        at org.apache.tools.ant.Main.main(Main.java)
--- Nested Exception ---
javax.xml.parsers.FactoryConfigurationError: Provider for javax.xml.parsers.SAXParserFactory
cannot be found
        at javax.xml.parsers.SAXParserFactory.newInstance(Unknown Source)
        at org.apache.tools.ant.util.JAXPUtils.newParserFactory(JAXPUtils.java)
        at org.apache.tools.ant.util.JAXPUtils.getParserFactory(JAXPUtils.java)
        at org.apache.tools.ant.util.JAXPUtils.newSAXParser(JAXPUtils.java)
        at org.apache.tools.ant.util.JAXPUtils.getXMLReader(JAXPUtils.java)
        at org.apache.tools.ant.helper.ProjectHelperImpl.parse(ProjectHelperImpl.java)
        at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java)
        at org.apache.tools.ant.Main.runBuild(Main.java)
        at org.apache.tools.ant.Main.start(Main.java)
        at org.apache.tools.ant.Main.main(Main.java)

Total time: 0 seconds
-----Original Message-----
From: Conor MacNeill [mailto:conor@cortexebusiness.com.au]
Sent: Wednesday, June 05, 2002 11:55 PM
To: Ant Users List
Subject: Re: 1.5 installation question


Alvarez, Gil wrote:
> Yeah, i think i put those in there to see if that would help. I took them
> out, same problem. Here's the new classpath:
> 
> [everything:gil:gil]/vobs/ben/com/pogo> ant
> CLASSPATH=/home/dev/gil/ant/jakarta-ant-1.5Beta2/lib/xmlapis.jar:/home/dev/g
> il/ant/jakarta-ant-1.5Beta2/lib/xercesImpl.jar:/home/dev/gil/ant/jakarta-ant
> -1.5Beta2/lib/
> optional.jar:/home/dev/gil/ant/jakarta-ant-1.5Beta2/lib/jakarta-regexp-1.2.j
> ar:/
> home/dev/gil/ant/jakarta-ant-1.5Beta2/lib/jakarta-oro-2.0.6.jar:/home/dev/gi
> l/ant/jakarta-ant-1.5Beta2/lib/ant.jar:/usr/local/jdk1.1.6/lib/classes.zip
> Buildfile: build.xml
> 

OK, try running with -debug flag - it may give more info - maybe not

Conor



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message