ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brown, Michael" <Michael_Br...@jdedwards.com>
Subject RE: XSLT issue with sending a parameter through javascript....
Date Mon, 03 Jun 2002 16:22:59 GMT
Your suggestion does work.

It must be a xalan specific issue.  It took way too long to figure out.  I
was blanking out while trying to get other tasks accomplished.  Thanks again
for your help.

Mike B.

-----Original Message-----
From: Diane Holt [mailto:holtdl@yahoo.com]
Sent: Monday, June 03, 2002 10:03 AM
To: Ant Users List
Subject: RE: XSLT issue with sending a parameter through javascript....


--- "Brown, Michael" <Michael_Brown@jdedwards.com> wrote:
> No.  This doesn't work.  It gives me a value but it doesn't have the
> single quotes around it.

Well, I don't know about whether the single quotes are actually needed or
not (they're not for me, but I'm not setting 'processor' to "xalan"), but
to get them included, just build up the string:

  expression = "'" + InitRetrieval.getProperty("jde.osrunning") + "'";
...
  pstyleparm.setExpression(expression);

Diane

=====
(holtdl@yahoo.com)



__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message