ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Hatcher" <jakarta-...@ehatchersolutions.com>
Subject Re: inheritrefs="true" is not working
Date Mon, 24 Jun 2002 03:21:01 GMT
----- Original Message -----
From: "Doug Lochart" <dlochart@cablespeed.com>

> Okay, I assume its something I am overlooking as I did not find a single
> post with my problem which generally would mean its me.  I have
ant1.5Beta2
> and I have double checked the version in my path.
>
> here are snippets of my 2 build files
>
> build file #1
>
>   <path id="build.classpath.cape">
>     <pathelement location="${classes.dir}"/>
>     <pathelement location="${common.utils.jar}"/>
>     <pathelement location="${rmi.utils.jar}"/>
>     <pathelement location="${logger.jar}"/>
>     <pathelement location="${jmx.jar}"/>
>     <pathelement location="${xerces.jar}"/>
>     <pathelement location="${methods.jar}"/>
>     <pathelement location="${bootstrap.jar}"/>
>   </path>
>
> <target name="common:build-main">
>     <ant inheritrefs="true"
>      antfile="${common.build.home}/scripts/common-build.xml"
>          target="build">
>       <reference refid="build.classpath"/>
>     </ant>
>   </target>

You've defined build.classpath.cape, but you're passing down build.classpath
(which is not defined in what you've shown).  Is that the problem?  You
shouldn't need inheritrefs="true" if you are using <reference>, or you can
omit <reference> and say inheritrefs="true" if you want all references
passed down.

    Erik



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message