ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran" <>
Subject Re: JUnitreport task differences between Ant 1.4 and Ant 1.4.1
Date Wed, 05 Jun 2002 22:40:42 GMT

----- Original Message -----
From: "Wesley Gamble" <>
To: <>
Cc: <>
Sent: Wednesday, June 05, 2002 2:19 PM
Subject: JUnitreport task differences between Ant 1.4 and Ant 1.4.1

> I am having some problems getting an Ant build file which works fine on
> 1.4 to work on 1.4.1.  Within this build file is a junitreport task.  It
> builds fine under Ant 1.4, but not under Ant 1.4.1.

As is usual in these situations, can you try ant1.5beta2 to see if
helps/changes your problem.

> Under Ant 1.4.1, it throws the following error:
> C:\Data\Dev\Policy\commons\build.xml:42: java.lang.NoClassDefFoundError:
> org/apache/xalan/xslt/XSLTInputSource

I am surprised you got this, certainly in the latest code there are meant to
be routines to catch this.

> I read several posts where people seemed to have similar problems.
>  Indeed, this class is not even in the xalan.jar that you are supposed
> to use in order to make Junitreport work.

no, but it is in Xalan1

> you get the exception shown above.  Note that I don't even have Xalan or
> Xerces JAR in my CLASSPATH - their presence doesn't change anything
> (their absence would matter if Ant ever got to trying to execute one of
> these targets).  This exception is thrown before any target processing
> is attempted.

the exception is thrown as the junit stuff is built, and at that time it
looks for xalan2, then xalan1. If you had xalan2 then you should not see it.

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message