ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Larsen" <lar...@qec.com>
Subject Compiling for JDK 1.1.8
Date Thu, 20 Jun 2002 16:42:23 GMT
I'm running Ant 1.4.1 under JDK 1.3.1. I need to
compile some projects to be run under JDK 1.1.8.

See the buld.xml below...

Ant is *NOT* properly compiling with JDK 1.1. I can
tell this two ways. During the compile, I get deprecation
warnings for things that were not deprecated until 1.2.
And also, some of my custom swing stuff just doesn't work
when I run it under 1.1.8.

If I execute ant using JDK1.1.8 my build is just fine.

What's up?

Jeff



<project name="Package qec.util" default="build" basedir=".">

  <property name="build.compiler"       value="javac1.1" />
  <property name="java.target"          value="1.1" />
  <property name="java.lib"
value="E:/jdk/jdk1.1.8/lib/classes.zip" />
  <property name="javax.swing"
value="E:/lib/swing-1.1.1/swing.jar" />

  <target name="init">
    <mkdir dir="${basedir}/classes" />
  </target>

  <target name="build" depends="init">
    <javac srcdir="${basedir}/src"
           destdir="${basedir}/classes"
           classpathref="class.path"
           deprecation="yes"
           includejavaruntime="no"
           includeantruntime="no"
           target="${java.target}"
    />
  </target>

  <path id="class.path">
    <pathelement location="${java.lib}" />
    <pathelement location="${javax.swing}" />
  </path>

</project>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message