ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran" <stev...@iseran.com>
Subject Re: Exception reading component ... ???
Date Mon, 17 Jun 2002 04:09:19 GMT

----- Original Message -----
From: "Elizabeth Barham" <soggytrousers@yahoo.com>
To: "Ant Users List" <ant-user@jakarta.apache.org>
Sent: Sunday, June 16, 2002 19:05
Subject: Re: Exception reading component ... ???


> "Erik Hatcher" <jakarta-ant@ehatchersolutions.com> writes:
> > Looks to me like ${lib} is not set.  No?
>
> Hi Erik,
>
> Thanks for your response but, yes, ${lib} was set. I'm not sure why
> either was calling an error but the current work-a-round is to call
> java with fork="yes" as it works from the command line:
>
>     <java
>   classname="org.txt2xml.cli.Batch"
>   fork="Yes"
>   classpath="${env.CLASSPATH}">
>       <arg file="${en.units.dsc}" />
>       <arg file="${en.units.txt}" />
>     </java>
>
> For any future references:
>
> The first error ("Exception reading component") was produced with Ant
> 1.4 and j2sdk1.4.0_01-i586.
>
> The second
> (java.lang.NoClassDefFoundError: sun/reflect/MethodAccessorImpl)
> was with Ant 1.5Beta2 and, again, with j2sdk1.4.0_01-i586.
>

ant1.4 would have the same bug. the classloader in ant filters out all
parent classes but java.* and javax.*; this was valid for pre-1.4. I am
planning to fix it, I have the fix, just not the tests yet.



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message