ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ylan Segal" <y...@digiworks.com.mx>
Subject RE: Possible bug in ant1.5beta1 - javadoc task
Date Tue, 07 May 2002 14:18:47 GMT
Stafan,

I define my project.classpath like this:

<path id="project.classpath">
	<fileset dir="${lib.home}">
		<include name="**/*.jar"/>
	</fileset>
</path>

In the lib.home dir there is a doccheck.jar that contains the custom doclet
I am using. This works fine with ant1.4.1 (I have both version installed on
my machine, so I can do some testing if you have any suggestions).

Thanks!

Ylan.
-----Mensaje original-----
De: Stefan Bodewig [mailto:bodewig@apache.org]
Enviado el: Martes, 07 de Mayo de 2002 03:47 a.m.
Para: ant-user@jakarta.apache.org
Asunto: Re: Possible bug in ant1.5beta1 - javadoc task


On Fri, 3 May 2002, Ylan Segal <ylan@digiworks.com.mx> wrote:

> 		docletpathref="project.classpath"

> BUILD FAILED java.lang.NullPointerException at
> org.apache.tools.ant.types.Reference.getReferencedObject(Reference.ja
> va:91) at

You didn't show the snippet that defines a <path> with the id
project.classpath, this maybe could help us to track the problem down.

Stefan

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>




--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message