ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Bailey" <ch...@wego.com>
Subject <javac> problem - isn't finding various source files/imports
Date Thu, 30 May 2002 22:26:34 GMT
I'm seeing an odd thing with the <javac> task in my project.  I have all my
sources in <root>/src/company/packagename/... hierarchy.  I have this for my
javac task:
        <property name="src" location="src"/>

        <javac srcdir="${src}" destdir="${classes}" sourcepath="${src}"
               debug="${debug}" failonerror="true"
               includes="**/*.java"
               classpathref="wego.classpath">
            <src path="${src}"/>
            <exclude name="company/*/ui_includes/**"/>
            <exclude name="company/utils/Blah.java"/>
        </javac>

build.xml is located in <root>, and that's where I run ant from.  It
compiles many of my sources just fine.  But, then, I get errors like this a
lot:

*** Error: "SomeClass" is either a misplaced package name or a non-existent
entity.

But, "SomeClass" is imported in the source file properly, and exists in the
source hierarchy.  I added the sourcepath attribute above, and the nested
<src path> (even though they're the same as the srcdir value), but I don't
see that passed to the javac compiler when I run ant in verbose mode.

Can anyone shed some light on this?  What might I be missing/doing wrong?

____
Chris Bailey       mailto:chris@codeintensity.com
Code Intensity       http://www.codeintensity.com


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message