ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BlyonsJ...@aol.com
Subject ANT Not Working - WIN2000 - j2sdk1.4.0
Date Fri, 17 May 2002 00:08:55 GMT
I am new to using Ant and J2EE.  I have been reading the documentation and 
cannot get Ant to run.  After downloading the binary zip file and extracting 
to directory called ANT, and setting the environment variables I type ant 
from the command line I get 'ant is not recognized as an internal or external 
command'.

I'm starting with the Java J2EE tutorial at 
http://java.sun.com/j2ee/tutorial/1_3-fcs/index.html and am using Ant build 
1.3 as the tutorial suggests.

My environment variables are set to:

ANT_HOME    C:\ANT
JAVA_HOME  C:\j2sdk1.4.0
J2EE_HOME   C:\j2sdkee1.3.1

Here is my classpath:

C:\Program Files\Microsoft.NET\FrameworkSDK\Bin\;C:\Program Files\Microsoft 
Visual Studio 
.NET\Common7\IDE\;C:\WINNT\Microsoft.NET\Framework\v1.0.3705\;C:\Program 
Files\Microsoft Visual Studio 
.NET\Vc7\bin\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:

\Program Files\Common Files\Adaptec Shared\System;C:\Program Files\Microsoft 
SQL 
Server\80\Tools\BINN;C:\jdk1.3.0_02;C:\j2sdk1.4.0;C:\j2sdkee1.3.1\bin;%ANT_HOM

E%\bin

I have also created the following directory to place the necessary 5 JAXP jar 
files in: C:\j2sdk1.4.0\jre\lib\endorsed

This endorsed directory now contains dom.jar, sax.jar, xercesImpl.jar, 
xalan.jar, and xsltc.jar

Where does the jaxp-api.jar go?

>From what I understand with j2sdk1.4.0, we must put dom.jar, sax.jar, 
xercesImpl.jar, xalan.jar, and xsltc.jar files in the endorsed directory to 
over ride earlier versions of the Xalan libraries.

Does Placing them in that directory make them available on the path and where 
do we put the jaxp-api.jar go?

I understand that in order to use Ant we must have JAXP-compliant XML parser 
installed and available on the classpath.  How do I do this?  I have 
downloaded everything I need to get started developing J2EE applications and 
cannot seem to get past this Ant hang up.  What am I doing wrong that I 
cannot get Ant to run?  Your help is greatly appreciated.  Thanks in advance.

Brian




--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message