ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Viraj Purang" <vpur...@bea.com>
Subject Re: Problems in setting path variables ...
Date Sat, 18 May 2002 00:00:33 GMT
Hi,
  I did set <property environment="env"/>.The problem is that if I hardcode
the values it works , bu tvalue replacement for variables does not take
place.
Regards,
Viraj Purang


----- Original Message -----
From: "Dominique Devienne" <DDevienne@lgc.com>
To: "'Ant Users List'" <ant-user@jakarta.apache.org>
Sent: Friday, May 17, 2002 3:03 PM
Subject: RE: Problems in setting path variables ...


> I assumed you did a <property environment="env" /> before try to get
> ${env.BEA_HOME}? --DD
>
> -----Original Message-----
> From: Viraj Purang [mailto:vpurang@bea.com]
> Sent: Friday, May 17, 2002 6:54 PM
> To: Ant Users List
> Subject: Problems in setting path variables ...
>
> Hi,
>    I am running a batch script as a part of my build process and I need to
> set the following variables
> before I run this script.
> PROJECT_HOME,  JAVA_HOME=c:\jdk1.3.1, ANT_HOME=%PROJECT_HOME%\ant,
> BEA_HOME=%PROJECT_HOME%\bea,   WL_HOME=%BEA_HOME%\weblogic600\server, set
> PATH=%PATH%;%JAVA_HOME%\bin;%ANT_HOME%\bin
>
> Can someone reason out why values of ${env.PROJECT_HOME} and
${env.BEA_HOME}
> would not get replaced in the following (I have attatched the target as
well
> as the ant -debug output)?
>
> --------------------------------------------------------------------------
--
> --------------------------------------------
>
> I tried
> <exec executable="C:/ANT/build_area/depot_sjfw/cajun_m1/bootstrap.cmd"
> os="Windows 2000" output="dir.txt">
>   <!--arg line="C:/ANT/build_area/depot_sjfw/cajun_m1/bootstrap.cmd"/-->
>   <env key="BEA_HOME" value="${env.PROJECT_HOME}\bea"/>
>   <env key="JAVA_HOME" value="c:\jdk1.3.1_03"/>
>   <env key="WL_HOME" value="${env.BEA_HOME}\weblogic700b\server"/>
>   <env key="ANT_HOME" value="C:\jakarta-ant-1.4.1"/>
>   </exec>
>
> but this gives debug output as
>
> build-env:
>      [echo] Number of Processors = 1
>      [echo] ANT_HOME is set to = C:\jakarta-ant-1.4.1
> Property ${env.PROJECT_HOME} has not been set
> Property ${env.BEA_HOME} has not been set
>      [exec] Current OS is Windows 2000
>      [exec] C:\ANT\build_area\depot_sjfw\cajun_m1\bootstrap.cmd
>      [exec] Output redirected to C:\ANT\build_area\dir.txt
>      [exec] Setting environment variable: BEA_HOME=${env.PROJECT_HOME}\bea
>      [exec] Setting environment variable: JAVA_HOME=c:\jdk1.3.1_03
>      [exec] Setting environment variable:
> WL_HOME=${env.BEA_HOME}\weblogic700b\s
> erver
>      [exec] Setting environment variable: ANT_HOME=C:\jakarta-ant-1.4.1
> Execute:Java13CommandLauncher:
> C:\ANT\build_area\depot_sjfw\cajun_m1\bootstrap.c
> md
>
> BUILD SUCCESSFUL
>
> Regards,
>
> Viraj Purang
>
>
>
>
>
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
>
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message