ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Gregg" <john.gr...@techarch.com>
Subject RE: <Property refid=> not working inside an ant task.
Date Tue, 07 May 2002 20:54:09 GMT
I encountered a similar problem recently with passing a <param> to
<antcall>, which also uses the Ant.java taskdef.  It appears to be a bug but
I haven't had time to submit the patch.  I've included the patch here.  This
should get you running, though the owner of this taskdef really needs to
have a look at the code and think about why it works the way it does (read:
I don't get it.)  Now when running I get a warning messsage about something
being redefined, but it doesn't seem to hurt anything.  I created this
patchfile from whatever revision of Ant.java comes with 1.4.1.

john




-----Original Message-----
From: ant-user-return-20228-john.gregg=techarch.com@jakarta.apache.org
[mailto:ant-user-return-20228-john.gregg=techarch.com@jakarta.apache.org
]On Behalf Of ROB
Sent: Tuesday, May 07, 2002 9:48 AM
To: ant-user@jakarta.apache.org
Subject: <Property refid=> not working inside an ant task.


This is for ant 1.4.1


 <property name="subapp.libs"      refid="catalog.classpath"/>

This works outside an ant task, but fails inside an ant task:

 <ant  antfile="build-subapp.xml"    target="compile">
    <property name="subapp.name"      value="catalog"/>
    <property name="subapp.libs"      refid="catalog.classpath"/>
  </ant>

Is this a know limitation, design decision ?

-Rob


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message