ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: setting a specific compiler
Date Fri, 26 Apr 2002 10:16:08 GMT
On Fri, 26 Apr 2002, Jamie Echlin <Jamie.Echlin@ubsw.com> wrote:

> which suggests it's got the 1.4 tools and rt but is not starting the
> 1.4 compiler...

Yes, you are correct.  I thought Ant would use the user specified
classpath when loading the compiler, but it doesn't (<rmic> does so,
at least in the weblogic case).  Sorry for the confusion.

One thing I haven't tried is forking <javac> - in 1.4.1 Ant didn't try
to be smart when searching for javac, it would use the javac that is
in your PATH.  Setting your PATH so that the javac of JDK 1.4 would be
used and using forked javac will probably work, but may break other
tasks.

Other than that <exec>ing a new instance of Ant is probably the only
choice in 1.4.1.

Stefan

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message