ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Barry Jia <>
Subject RE: cvs at ant
Date Wed, 06 Mar 2002 22:57:02 GMT

I verofied, that is not problem. from my ant target, the ant debug show me
that ant interprete the target to Dos command 
"cvs -d :pserver:bjia@tira-src:/var/local/tira-cvs checkout code-injection",
then it generates exception.
if I run this command in dos window, it works! my ${CVSROOT} is
":pserver:bjia@tira-src:/var/local/tira-cvs", that is no problem. It causes
me crazy!

-----Original Message-----
From: Diane Holt []
Sent: Wednesday, March 06, 2002 5:50 PM
To: Ant Users List
Subject: RE: cvs at ant

--- Barry Jia <> wrote:
> cvs.exe is in my path, and the debug info
> " cvs -d :pserver:bjia@tira-src:/var/local/tira-cvs checkout
> code-injection"
> generate exception,
> but if I run this command in same terminal, it works ! it can check out
> everything, I do not know which directory is invalid now if Error code
> 267
> means invalid directory.
> in my build file like below, how to set up cvx.exe absolute path for
> cvs.exe
> ?
>  <target name="checkout">
>       <cvs cvsRoot="${CVSROOT}"
>            package="code-injection"
>            dest="code-injection"
>            passfile="${passfile}"
>        />
>    </target>

Maybe your ${CVSROOT} property value is incorrect, or maybe the
"code-injection" directory needs to exist first (if it doesn't already)?

(Just speculating, though, since I've not used the <cvs> task.)



Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message