ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Rousse <rou...@ccr.jussieu.fr>
Subject Re: javadoc get confused by java package running jsdk-1.4
Date Thu, 14 Mar 2002 10:55:10 GMT
Ainsi parlait Stefan Bodewig :
> On Wed, 13 Mar 2002, Guillaume Rousse <rousse@ccr.jussieu.fr> wrote:
> > Anyway, and before this is fixed in a next jdk release, any
> > workaround idea ?
>
> You said it worked from the command line (just using a different
> command than Ant did).  Which command did you use?
-subpackages options, which is javadoc 1.4 specific :-(

> You can use <exec> instead of <javadoc> with the command that worked
> for you.  You won't have any performance impact as Ant forks a new VM
> for <javadoc> anyway.
So i need to test jdk version first, use an exec task if 1.4, and a javadoc 
task in the opposite case. I'll try this.
-- 
Guillaume Rousse <rousse@ccr.jussieu.fr>
GPG key http://lis.snv.jussieu.fr/~rousse/gpgkey.html

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message