ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject RE: Running Ant gives Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tools/ant/
Date Mon, 04 Feb 2002 04:47:31 GMT
I suggest moving it to D:\ant or D:\ant141

I am pretty sure the two "." in your ANT_HOME would make 98 consider this to
be a long path. Due to limitations of 98, Ant must be installed in a short
path.

If that doesn't work, edit the ant.bat file and turn echo on to see what is
going wrong.

Conor



> -----Original Message-----
> From: Al Caponi [mailto:don_alcaponi@yahoo.com.sg]
> Sent: Monday, 4 February 2002 2:35 PM
> To: Mailing List, Ant User
> Subject: Running Ant gives Exception in thread "main"
> java.lang.NoClassDefFoundError: org/apache/tools/ant/
>
>
> Hi all,
>
> I've just installed Ant1.4.1 from binary on Win98 according to the
> installation manual.
> Still, I get the following when I type 'ant' at command-line.
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/tools/ant/
> Main
>
> I set the environment variables as follows in autoexec.bat:
>
> SET ANT_HOME=D:\ant1.4.1
> SET PATH=%PATH%;%ANT_HOME%\bin;%ANT_HOME%\lib
>
> Can anyone help?
> Thanx!
> Al
>
>  _________________________________________________________ Do You
> Yahoo!? Get your free @yahoo.com address at http://mail.yahoo.com
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message