ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ajay Chitre <ajay.chi...@diligentteam.com>
Subject RE: Hot Deploying EJBs on Weblogic 6.1
Date Wed, 20 Feb 2002 21:01:28 GMT
1)  Yes, ProductionModeEnabled is set to 'false'.

2)  Just copying the deployable jar to /applications doesn't work for me
either.

3)  I apologize for asking Weblogic related question on Ant user list. 
But I strongly believe that there are enough Weblogic experts on this mailing
list who could help me on this.  Plus I thought that the answer to this
question might be useful to some other people using Ant as well.  Anyway,
sorry..., next time I will be more careful :)

Thanks.

-- Original Message --

>Hot deploy is a 'development mode' setting.  Make sure you have set this
>by 
>
>-Dweblogic.ProductionModeEnabled=false
>
>In that instance you do not need to use the weblogic.deploy utility, just
>copy your deployable to the $WLHOME/config/mydomain/applications directory.
>
>As this is not really an ant specific question, you should proabably seek
>further help on the weblogic.* newsgroups.
>
>Cheers,
>Paul
>
>> -----Original Message-----
>> From: Ajay Chitre [mailto:ajay.chitre@diligentteam.com]
>> Sent: Wednesday, February 20, 2002 12:12 PM
>> To: ant-user@jakarta.apache.org
>> Subject: Hot Deploying EJBs on Weblogic 6.1
>> 
>> 
>> Hello,
>> 
>> Has anyone developed an Ant task that runs "weblogic.deploy" 
>> program?  If
>> nobody has then I would like to, but unfortunately, I can't 
>> get weblogic.deploy
>> program to "hot deploy" EJBs.  Please help...
>> 
>> After reading the Weblogic documentation at 
>> http://edocs.bea.com/wls/docs61/ejb/deploy.html#1071018
>> , here's what I tried;
>> 
>> 1)  Ran the following command;
>> 
>> java weblogic.deploy update mypassword myEJB myEJB.jar
>> 
>> (Tried several different variations of this command)
>> 
>> 2)  Deployed the EJB in Weblogic console as per the 
>> instructions under 'Updating
>> the EJB' section.
>> 
>> But every time my application uses this EJB I get the 
>> following message;
>> 
>> *****Error retrieving the message bundle.******
>> 
>> Please help....  Thanks.
>> 
>> 
>> Ajay Chitre
>> 
>> Diligent Team, Inc.
>> (Where Diligent People Work as a Team)
>> 
>> http://www.DiligentTeam.com
>> 
>> 
>> 
>> --
>> To unsubscribe, e-mail:   
><mailto:ant-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
>
>--
>To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
>
>




--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message