ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Holdener <ste...@mail.amnesiac.net>
Subject Re: W2000 SP1 Delete of directory fails
Date Wed, 06 Feb 2002 16:47:55 GMT
Martin van Wieringen wrote:

> When I have a build.xml file which creates the build directory, compiles 
> the classes to the build directory then put the .class file on a jar file 
> in the dist directory and at the end deletes the entire build directory. It 
> works fine however if I envoke the build two times after each other then it 
> W2000 seems to lock the build directory so that the second build result in 
> failure when it tries to recreate the directory.


I saw similar behavior on my W2000/SP2 box yesterday.  I closed all open 
apps, and it still wouldn't delete the directory ("Access Denied"), so I 
rebooted.  I suppose this is a workaround for now...that, or don't use 
Windows.  < drifts off in a daydream about Linux, smiles wistfully >

BTW, after Ant attempts to delete the directory, the dir appears stuck 
in some strange limbo state.  It will show up in the explorer, but I 
can't even select it without getting the error.  IIRC, I was not able to 
see it from a command prompt.  I've not been able to reproduce this 
today, but I'll let you know if I can get any more details.


-Steve


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message