ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank E. Weiss" <fra...@well.com>
Subject Re: Could someone help me out ?
Date Fri, 01 Feb 2002 19:59:30 GMT


"Atluri, Vamsi NYC" wrote:

> I have been having problems with the ANT ftp task and telnet tasks
>
> when i do the following:
>
>                 <ftp server="myserver"
>                         port="2121"
>
> remotedir="/export/home/vatluri/application/citco/cas/webapps/cas"
>                         userid="name"
>                         password="name"
>                         binary="yes"
>                 >
>                         <fileset dir="${buildCas}">
>                         <include name="**/xml.tar"/>
>                         </fileset>
>                 </ftp>
>
> i recieve the following:
>
> BUILD FAILED
> C:\webadmin.xml:140: Could not create task or type of type: ftp.
> Ant could not find the task or a class this
> task relies upon.
> Common solutions are to use taskdef to declare
> your task, or, if this is an optional task,
> to put the optional.jar and all required libraries of
> this task in the lib directory of
> your ant installation (ANT_HOME).
> There is also the possibility that your build file
> is written to work with a more recent version of ant
> than the one you are using, in which case you have to
> upgrade.
>         at
> org.apache.tools.ant.UnknownElement.getNotFoundException(UnknownEleme
> nt.java:228)
>         at
> org.apache.tools.ant.UnknownElement.makeObject(UnknownElement.java:18
> 8)
>         at
> org.apache.tools.ant.UnknownElement.maybeConfigure(UnknownElement.jav
> a:99)
>         at org.apache.tools.ant.Task.perform(Task.java:222)
>         at org.apache.tools.ant.Target.execute(Target.java:186)
>         at org.apache.tools.ant.Target.performTasks(Target.java:204)
>         at org.apache.tools.ant.Project.executeTarget(Project.java:921)
>         at org.apache.tools.ant.Project.executeTargets(Project.java:875)
>         at org.apache.tools.ant.Main.runBuild(Main.java:481)
>         at org.apache.tools.ant.Main.start(Main.java:159)
>         at org.apache.tools.ant.Main.main(Main.java:183)
> ----------------------------------------------------------------------------
> ------------------------------------------
>
> I have downloaded the netcomponents.jar and added it to my classpath.
>

You probably have to put these jars in Ant's lib directory. I think there are several other
complaints about Ant's not
handling classpath corectly.



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message