ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran" <stev...@iseran.com>
Subject Re: target selection: sthg wrong in the installation ?
Date Tue, 26 Feb 2002 23:28:31 GMT

I bet there is something wrong with your env variables (esp CLASSPATH) which
is causing confusion.

1 .find ant.bat (in ant\bin),
2. turn off the echo statement on line 1
3. call ant and see what gets printed



----- Original Message -----
From: "LABURTHE, Fran├žois" <flaburthe@bouygues.com>
To: <ant-user@jakarta.apache.org>
Sent: Tuesday, February 26, 2002 10:13
Subject: target selection: sthg wrong in the installation ?


I installed jakarta-ant-1-4-1 under Windows NT4:
  - unzipped the archive and put everything into d:\sys\ant
  - defined the environment variable ANT_HOME
  - added d:\sys\ant\bin to the PATH environment variable
  (I use a jdk1.3, installed in d:\sys\java\jdk1.3 and JAVA_HOME is already
defined as d:\sys\java\jdk1.3)

Tried to use the simplest build.xml file I could come up with

<project name="trivialproject" default="talk" basedir=".">
  <target name="talk">
    <echo>
       Hello world
    </echo>
  </target>
</project>

When calling 'ant' or 'ant talk', I got the following answer (as if ant had
tried to select as a target
the first file in the current directory, e.g. build.bak)

Buildfile: build.xml
BUILD FAILED
Target `build.BAK' does not exist in this project.
Total time: 0 seconds

Anyone has an indea on what I am doing wrong. Did I miss something in the
installation ?

Thanks,

Fran├žois

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>




--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message