ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Hatcher" <jakarta-...@ehatchersolutions.com>
Subject Re: How to tell if a Ant build script is running in Eclipse?
Date Fri, 15 Feb 2002 20:46:06 GMT
How about using <available> for that classname before setting
build.compiler?

Or when running outside of Eclipse set build.compiler from the command-line
with -Dbuild.compiler=modern or something like that?  (Remember, properties
are immutable!)

    Erik


----- Original Message -----
From: "Jiang, Bianca" <BJiang@rational.com>
To: <ant-user@jakarta.apache.org>
Sent: Friday, February 15, 2002 11:51 AM
Subject: How to tell if a Ant build script is running in Eclipse?


> I had this compiler problem when running Ant in Eclipse.  Then found
> the workaround of adding one property to the build file to make it work:
> <property name="build.compiler"
> value="org.eclipse.pde.internal.core.JDTCompilerAdapter"/>
>
> But it's only helps if the script is generic and can
> work the same both in and out Eclipse.  So anybody
> knows if there is a way to check if the build script
> is running inside Eclipse or not so that can set the
> property conditionally?
>
>
> Thanks,
>
> Bianca
>
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message